Knowledge base | Kayla Itsines

Android Compatibility

Sweat with Kayla requires Android 4.4 to function and does not support anything older than this.

To check what version of Android your device is currently running, follow the below steps:

  1. Open your device ‘Settings’.

  2. Scroll down towards the bottom of the menu.

  3. Select ‘About phone’.

  4. Check the number under ‘Android version’. The number(s) listed there indicate the version of Android your device is currently running. For SWK you will need to see the number 4.4 or greater.

If you're having any further troubles be sure to get in touch with our team via the 'Contact Us' tab at the bottom of this screen.

Please mention "Android Compatibility" in the subject of your enquiry.